A little bit of code completion, please (Latex)

Discussion Forums discussion A little bit of code completion, please (Latex)

This topic contains 0 voices and has 1 reply.

Viewing 2 posts - 1 through 2 (of 2 total)
Author Posts
Author Posts
April 26, 2011 at 4:02 pm #5265

Huge
Member

Hi, Im using PN on everyday basis for it’s incedible speed and very smart feature set.

Currently I’d like to shift my relationship with PN a bit, using it for editing simple (one file) Python and Latex scripts. The only hassle is practically no code completion support (although the feature itself seem to be implemented ).

After some research I thought that completion can be obtained with having the (constant) keywords listed in the appropriate scheme file, so I went to insert plain list of latex commands as I saw it in the Python scheme. There this worked correctly including the pop-up box for (although having only the language keywords doesn’t help much).

Sadly I didn’t succeed and even when I go to menu Tools->Options->Fonts and Colours->Advanced->Keywords, I see only one keyword class named “Keywords”, with no words included.

I edited the file latex.scheme so that the beginning looked like:

<?xml version=”1.0″ encoding=”UTF-8″?>

<Scheme>

<keyword-classes>

<keyword-class name=”latexCommands”>

begin

</keyword-class>

</keyword-classes>

(…)

Where I’m I wrong? Im I on the right way, at least?

Thank for your advise, if this worked, it would be awsome, because this way I could add the as keywords the commands of all packages I mostly use and same for the standard libraries of Python, which would be in half of the way to perfect.

April 27, 2011 at 10:18 am #17803

CoDEmanX
Member

I put couple LaTeX commands into the scheme file, tried \widetilde and widetile

added wordchars-attribute to language tag (a-z, A-Z, 0-9, underscore, minus and backslash)

also created an API file

but: it did not work. I then removed the leading backslash – worked.

AutoComplete doesn’t seem to work with backslash characters, so you did it right but there’s an internal limitation.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.