Any Progress with Bug #1375688

Discussion Forums discussion Any Progress with Bug #1375688

This topic contains 0 voices and has 6 replies.

Viewing 7 posts - 1 through 7 (of 7 total)
Author Posts
Author Posts
January 15, 2006 at 2:24 pm #9

jreinhardt
Member

Hi everybody!

Sorry for bugging you, but I wanted to ask if you have made any progress with Bug #1375688 in the Sourceforge Tracker.

Its really bad that my favourite editor doesn’t work. I should write some LaTeX documents for university, but its so annoying using another tool than PN for that.

If you need more Information, I will try to find out.

Ah, perhaps this one is important: I tried to install older versions of PN, but at least 2.0.5.48 and 2.0.6 showed the bug, too.

Once more: I really really like this tool and used to use it almost everyday, until this bug made it unusable.

Greetings

Johannes

January 15, 2006 at 6:54 pm #14770

simon
Key Master

Hi Johannes,

I’ve not had much luck yet, but could you please try deleting the following registry key and then starting PN2 to see if it makes any difference?

HKEY_CURRENT_USERSoftwareEcho SoftwarePN2Interface Settingsdefault

I will try and fix it, I’m just having no luck reproducing the problem. I run PN on a multi-monitor system with 2560 horizontal pixels and on my laptop with 1280 and no problems on either.

Thanks,

Simon.

January 15, 2006 at 9:12 pm #14771

jreinhardt
Member

Heyhey, you are the man!

It worked. All Problems are gone!

What does this key do, and how could I have borked it?

Thank you very much!

January 17, 2006 at 10:33 pm #14772

jreinhardt
Member

Ok, here some news:

The bug returned. A few days everything was fine, but now there is again a “dead” bar at the bottom.

I am not sure if it helps, but I noticed some invalid dwords when looking through the registry key you told me about.

Here is a link to a reg file with the default key:

http://web3.gleitz.org/Kopernikus/pnotepad.reg

I will try to find out what it is triggering the bug.

February 4, 2006 at 12:22 pm #14773

jreinhardt
Member

Hi again,

I made another observation that might help.

After I deleted the reg key as you told me, everything worked just fine.

Now I tried the Matlab Scheme from here

http://pnotepad.org/forums/topic/15?replies=3

I copied it into the schemes folder in the PN dir. Then I started PN and there were “holes” again. The scheme worked, but suddenly PN crashed.

When I restarted PN, the holes stayed, but it didn’t crash since then.

Deleting the reg key solves it again.

Hope it helps

February 4, 2006 at 8:27 pm #14774

simon
Key Master

Doh, I just closed the bug off too! Ok it looks like there’s some more debugging to do here. Thanks for the .reg file that will be helpful.

February 4, 2006 at 8:29 pm #14775

simon
Key Master

Hmm, the odd DWORDs are deliberate, the docking windows start at -1 and go down (don’t ask why – I don’t know!)

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.