bug: comment after end subroutine (fortran 95)

Discussion Forums discussion bug: comment after end subroutine (fortran 95)

This topic contains 0 voices and has 3 replies.

Viewing 4 posts - 1 through 4 (of 4 total)
Author Posts
Author Posts
February 19, 2010 at 3:13 pm #1132

lgriffiths
Member

Using fortran 95 syntaxing, the following crashes pn on either save, or open. Its the final tabbed comment which seems to be the issue.

Can anyone else confirm this?

!***** this line is not part of the code

!ANYTHING ABOVE HERE IS FINE

END SUBROUTINE

!NOTE THE BLANK SPACE ABOVE, THIS COMMENT IS TABBED IN.

!***** this line is not part of the code

EDIT: the tab in the comment line doesnt seem to show up on my post. But it is supposed to be there, doesnt crash if i remove the tab.

February 19, 2010 at 3:32 pm #16996

simon
Key Master

Hi, I don’t see this with the code you’ve placed above, tried putting the tab all over the place and saving. Could you perhaps attach a file that reproduces the problem to an issue here:

http://code.google.com/p/pnotepad/issues/entry

I’ll see if I can reproduce that way. Finally, what version of PN are you using?

February 20, 2010 at 3:14 am #16997

lgriffiths
Member

sure i’ll upload one now. i’m running it on v2.0.10.1010 portable edition.

let > represent a tab and n a new line, the file is, without any other white space:

Code:
end subroutinen
n
>!comment, not followed by new line

**Interestingly the following is fine:

end subroutinen
>!comment followed by a new linen
[code]

[code]

end subroutinen

>!comment followed by a new linen

[code]

February 22, 2010 at 12:03 pm #16998

simon
Key Master

Thanks, I’ve been able to reproduce this now, it appears to be a bug in ctags – ctags just sticks in a tight loop when trying to find tags in this file. You can at least end the ctags process and this will unblock PN until we work out how to fix it.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.