Extension SDK: –findexts not working

Discussion Forums discussion Extension SDK: –findexts not working

This topic contains 2 replies, has 2 voices, and was last updated by  simon 1 year ago.

Viewing 3 posts - 1 through 3 (of 3 total)
Author Posts
Author Posts
June 18, 2013 at 11:34 pm #19862


I tried to build a few projects – including demo and template, the ones included with the sdk – and them plug into PN, but –findexts doesn’t seem to be working for them.

Boost: 1.53.0
VS: 2005 Pro

1) Open demo project
2) Go to properties, C/C++ and add boost to the Additional Include Directories
3) Build solution
4) Copy demo.dll from debug or release folder to C:\Program Files (x86)\Programmer’s Notepad
5) Open cmd, run pn –findexts (note that pn doesn’t open, so presumably –findexts runs)
6) Open PN
7) Go to Tools, Options, Extensions. Demo extension is not there.

Am I doing something wrong?

June 20, 2013 at 9:05 pm #19869


Figured out part of the problem. The SDK version that’s linked from the PN website is old, so any plugins created with that will automatically be rejected. Had to get the new SDK from hg repo (hg clone https://code.google.com/p/pnotepad-plugins/). Template works now, but Demo still fails to load on

September 12, 2013 at 1:55 pm #20006

Key Master

Which version of Visual Studio are you building with?

Sorry the web sdk was out of date, I’ll get around to fixing that.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.