Font randomly reverts to Arial?

Discussion Forums discussion Font randomly reverts to Arial?

This topic contains 0 voices and has 9 replies.

Viewing 10 posts - 1 through 10 (of 10 total)
Author Posts
Author Posts
October 12, 2006 at 6:07 pm #128

drano
Member

For some reason, if I change the font in the scheme config, sometimes it completely stops working and reverts to Arial. I can’t fix it even between instances.

I’d say this is a bug. Any idea?

October 14, 2006 at 1:59 am #15146

TimTate
Member

This started happening to me today, too. After playing around with it I found that switching the font to Lucida Console or Courier New both work, but every other font I tried just shows up as Arial.

October 14, 2006 at 9:36 pm #15147

simon
Key Master

Hmm I haven’t come across this one before. What version are you using?

October 15, 2006 at 11:58 pm #15148

TimTate
Member

I’m using v2.0.7.610-devel

October 17, 2006 at 6:22 pm #15149

drano
Member

Same here.

November 3, 2006 at 3:16 am #15150

Bjoern
Member

Looks like disabling the indentation guides triggers this, at least in version 2.0.7.619-dev.

November 3, 2006 at 11:45 am #15151

simon
Key Master

Thanks – I haven’t been able to reproduce so far so that will help. It’s worth pointing out that there has been lots of code change in the schemes stuff for 2.0.7 so I was surprised I hadn’t seen any problems before now!

November 11, 2006 at 5:45 pm #15152

bcat
Member

Hmm, I just noticed that earlier today. I was trying to tweak my font/color settings and the font kept getting screwed up. I think it has to do with a bug in the default charset preference. Here’s how I can reproduce it:

1) Open options/defaults; set character set to default. Close options.

2) Open options/defaults again. Character set has reset to ANSI. Close options.

2) Open options/defaults again. Character set is now *blank*. Close options.

That should switch it to a proportional font (Arial?). To fix it, just fill in the default charset set.

I’ve only noticed this since I switched to 2.0.7.610-devel. 2.0.7.609 was fine for me.

November 18, 2006 at 7:11 pm #15153

dandersahn
Member

I was having this exact same problem. Whenever I tried to apply certain fonts, the text would revert to Arial. After updating the charset setting from <blank> to ANSI, the problem was solved. Don’t know if that helps.

Using 2.0.7.619-devel

November 19, 2006 at 5:56 pm #15154

simon
Key Master

Ok, found the charset bug and fixed it. Most likely the reason that people were seeing Arial is that it’s Windows’ default fallback font. Next release will fix this properly.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.