Incorrect handling of international characters

Discussion Forums discussion Incorrect handling of international characters

This topic contains 0 voices and has 2 replies.

Viewing 3 posts - 1 through 3 (of 3 total)
Author Posts
Author Posts
February 20, 2011 at 5:33 pm #5207

pepak
Member

Hi!

In the default configuration PN seems to incorrectly handle international characters. I expect there are settings which I could use to fix the problem, but I can’t seem to find them. Could anyone please direct me to the right place, or, if these are real bugs, may I ask for a fix? Thank you.

Assume this sentence:

Kapitán se na nás povzbudivě usmál.

(It doesn’t matter what it means, just that it has national characters in it.)

1. Cursor navigation using CTRL+leftarrow and CTRL+rightarrow considers the national character as word-breaks. If I start at the “K” at the beginning and keep pressing CTRL+right, I get stops at (marked with asterisk):

Kapit*á*n *se *na *n*á*s *povzbudiv*ě *usm*á*l*.

The proper sequence should be:

Kapitán *se *na *nás *povzbudivě *usmál*.

2. When using the b in PCRE search, the accented characters are also considered word breaks. When searching for bkapitb, I get a match at the beginning of the sentence, but I shouldn’t. When searching for bkapitánb, I do get a proper match, though. Another editor I use, which also uses the PCRE library, works correctly with both expressions (but as it lacks some features of PN, I need to use both the editors).

March 3, 2011 at 11:16 pm #17635

simon
Key Master

Suggest you set your default encoding to a unicode one, e.g.

Options | Defaults | Encoding: UTF-8

If the search still doesn’t work then please file an issue:

http://code.google.com/p/pnotepad/issues/entry

March 14, 2011 at 6:45 pm #17636

pepak
Member

I am afraid changing the encoding doesn’t affect the descibed behavior. I will try to file an issue now.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.