schemedef doesn’t work

Discussion Forums discussion schemedef doesn’t work

This topic contains 0 voices and has 4 replies.

Viewing 5 posts - 1 through 5 (of 5 total)
Author Posts
Author Posts
May 17, 2009 at 11:11 am #598

maXmo
Member

It appears in options dialog and file associations settings, but it doesn’t appear in dropdown box and in menu, when I try to set it in file associations, style changes to plain text. What’s wrong?

<?xml version="1.0" ?>

<Scheme>

<keyword-classes>

<keyword-class name="c2types">

auto bool char class const double enum explicit export extern float

friend inline int long mutable private protected public register

short signed static struct template typedef typename union unsigned

virtual void volatile wchar_t

int8_t uint8_t int16_t uint16_t int32_t uint32_t int64_t uint64_t

intptr_t uintptr_t

</keyword-class>

<keyword-class name="c2sttm">

asm break case catch const_cast continue

default delete do dynamic_cast else false for goto if

namespace new operator reinterpret_cast return sizeof static_cast switch

this throw true try typeid using while

and and_eq bitand bitor compl not not_eq or or_eq xor xor_eq

</keyword-class>

<keyword-class name="c2attrs">

__cdecl __declspec __stdcall

</keyword-class>

<keyword-class name="c2winapi">

BOOL WCHAR INT UINT LONG ULONG SHORT USHORT BYTE WORD DWORD QWORD

NULL TRUE FALSE

HRESULT LRESULT LCID DISPID

HANDLE HMODULE HINSTANCE

REFIID REFCLSID

IID CLSID VARIANT

</keyword-class>

</keyword-classes>

<schemedef name="ccustom2" title="C (2)" author="maXmo" version="1"

casesensitive="true" braces="{[()]}">

<!– Max 2 –>

<strings>

<stringtype id="0" start="’" end="’" multiline="false"/>

<stringtype id="1" start=""" end=""" multiline="false"/>

</strings>

<identifiers start="[a-zA-Z]" content="[a-zA-Z0-9]"/>

<comments>

<line start="//"/>

<block start="/*" end="*/"/>

</comments>

<numbers start="[0-9]" content="[0-9a-fx.]"/>

<!–preprocessor start="#" continuation=""/–>

<!– From here on is the traditional scheme definition block… –>

<lexer name="ccustom2"/>

<use-styles>

<style name="Default" key="32"/>

<style name="Line Comment" key="1" class="comment"/>

<style name="Block Comment" key="2" class="comment"/>

<style name="Identifier" key="3" class="identifier"/>

<style name="Number" key="4" class="number"/>

<style name="Types" key="5" class="keyword"/>

<style name="Statements" key="6" class="keyword" fore="8601de"/>

<style name="Attributes" key="7" class="keyword" fore="c800c8"/>

<style name="WinApi" key="8" class="keyword" fore="338080"/>

<style name="Char" key="10" class="string"/>

<style name="String" key="11" class="string"/>

<!–style name="Pre-Processor" key="12" class="preprocessor"/–>

<!–style name="Special Identifier" key="13" fore="478698"/–>

</use-styles>

<use-keywords>

<keyword key="0" name="Types" class="c2types"/>

<keyword key="1" name="Statements" class="c2sttm"/>

<keyword key="2" name="Attributes" class="c2attrs"/>

<keyword key="3" name="WinApi" class="c2winapi"/>

</use-keywords>

</schemedef>

</Scheme>

May 17, 2009 at 11:13 am #16454

maXmo
Member

second string is with quots

<stringtype id="1" start=""" end=""" multiline="false"/>

May 17, 2009 at 11:14 am #16455

maXmo
Member

<stringtype id="1" start=""" end=""" multiline="false"/>

May 17, 2009 at 11:15 am #16456

maXmo
Member

<stringtype id="1" start=""" end=""" multiline="false"/>

May 17, 2009 at 11:36 am #16457

maXmo
Member

Found solution: http://pnotepad.org/forums/topic/291#post-1088

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.