Trouble Installing PyPN

Discussion Forums discussion Trouble Installing PyPN

This topic contains 0 voices and has 11 replies.

Viewing 12 posts - 1 through 12 (of 12 total)
Author Posts
Author Posts
January 14, 2011 at 12:29 pm #5164

Patabugen
Member

I’m trying to setup PyPN to make use of some of the python scripts available. I’m not much of a Python user (yet!) so I might be messing something up with installing Python.

I’m on x64 Windows 7 with PN v2.2.0.2240-ellington.

I’ve installed this:

http://www.python.org/download/releases/2.6.6/

Then extracted this into my PN dir:

http://pnotepad.googlecode.com/files/pypn-0.10.973-py26.zip

And run

pn.exe –findexts

Running the last command gives no output (but not does it open the windows) so I’m guessing it’s either worked, or gone very wrong.

My scripts/ folder then has the default scripts in, but the Scripts windows is empty and I’m not sure what else to check.

PN was closed the whole time I installed.

I’m not sure what to do now, how can I check whether any of the steps above have worked?

January 14, 2011 at 1:26 pm #17502

simon
Key Master

Ok, my first guess is that you’ve installed 64-bit Python. Because Programmer’s Notepad is still a 32-bit application, we need to link to 32-bit Python.

If I’m wrong, we’ll work out what to try next!

(and there shouldn’t be any output from PN on –findexts currently, so that’s fine)

January 14, 2011 at 2:16 pm #17503

Patabugen
Member

edit: Just saw your reply!

I had a similar thought, and have installed Python 32bit with the same results.

January 16, 2011 at 2:26 am #17504

Nux
Member

Have you tried running pn.exe –findexts as an administrator (e.g. by creating a shortcut to pn.exe with this param)?

January 16, 2011 at 10:09 am #17505

Patabugen
Member

The account I use is an Administrator account. I’ll try it with _the_ administrator account on Monday but I can’t see it making much difference.

January 17, 2011 at 11:48 am #17506

simon
Key Master

I just realised what I overlooked earlier, I think you have an old version of PyPN, you want:

http://pnotepad.googlecode.com/files/pypn-0.12.2222-py26.zip

This should work!

January 17, 2011 at 12:05 pm #17507

Patabugen
Member

Beautiful! Thank you :)

It was the Zen Coding script which got me, finally, to decide to look at PyPN :) I now have it working. Though I noticed you cannot use “tab” as a shortcut key, or even as part of it.

http://code.google.com/p/pnotepad/issues/detail?id=1180

August 2, 2011 at 4:47 pm #17509

muradkhan
Member

I had this working on another machine. This time however, I used PyPn pypn-1.0.2300-py26, and the record button does not appear to activate. There is no output when running –findexts.

My questions:

How does one un-install an extension

How does one check to see what extensions are installed

AdThanksVance

August 3, 2011 at 1:33 pm #17510

CoDEmanX
Member

Uninstall:

Open the config.xml file, either stored in settings (portable edition) or in %appdata%Echo SoftwarePN2

Remove the extension tag of the extension you wanna uninstall, e.g. delete

<extension path=”pypn.dll”></extension>

Save changes and restart PN

Installed Extensions:

Run PN, open Tools > Options > Extensions

Screenshot

September 2, 2011 at 4:17 pm #17511

CraigInDallas
Member

I am not getting the extensions showing in PN after installation. I am trying to install PyPN and TextUtils. Since I did not see a requirement that Python 2.6 is the only acceptable version, I went through the (avoidable) installation of different versions of Python. Not surprisingly, installing Python 2.6 eliminated the problem with the python 2.6 dll missing. Running “pn –findexts” (as Administrator) from the command line ran without any messages about success or failure. However, when I load PN none of the extensions are listed under “Tools” | “Options” | “Extensions”. I looked at the XML config file and both extensions are listed.

I next tried removing the listings in the XML config file and rerunning the “pn –findexts”. Got the same results. The extensions show up in the config file but PN does not seem to load them.

Any ideas about what I’ve done incorrectly?

September 5, 2011 at 12:31 pm #17512

simon
Key Master

Hmm, well you shouldn’t need to use Administrator any more for this, it now stores the settings in your per-user directory. So to check the config.xml you want to look here:

C:Users[your user name]AppDataRoamingEcho SoftwarePN2config.xml

Failing that, are there any entries in the event log about these DLLs failing to load?

September 9, 2011 at 8:44 am #17513

CoDEmanX
Member

PyPN works fine for me (v2.3.4.2350-charles), but TextUtil did not load – I used the link found on http://www.pnotepad.org/add-ons/ (it’s for v2.2!)

The proper Textutil download is here: http://code.google.com/p/pnotepad/downloads/detail?name=textutil-0.2.zip&can=2&q=

It loads and works, but appears to be buggy:

http://code.google.com/p/pnotepad/issues/detail?id=1432

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.